Shell Command Injection

Affecting org.codehaus.plexus:plexus-utils artifact, versions [,3.0.16)

high severity

Overview

Codehaus Plexus is a collection of components used by Apache Maven.

Affected versions of this package are vulnerable to Shell Command Injection. The Commandline class in plexus-utils does not correctly quote the contents of double-quoted strings.

Remediation

Upgrade Codehaus Plexus to version 3.0.16 or higher.

References

Do your applications use this vulnerable package?

Credit
Charles Duffy
CVE
CVE-2017-1000487
CWE
CWE-77
Snyk ID
SNYK-JAVA-ORGCODEHAUSPLEXUS-31522
Disclosed
08 May, 2016
Published
20 Sep, 2016