Denial of Service (DoS)

Affecting org.apache.commons:commons-compress artifact, versions [,1.18)

Do your applications use this vulnerable package? Test your applications

Overview

org.apache.commons:commons-compress defines an API for working with compression and archive formats.

Affected versions of this package are vulnerable to Denial of Service (DoS) attacks. When reading a specially crafted ZIP archive, the read method might fail to return the correct EOF indication after the end of the stream has been reached. If it combined with a java.io.InputStreamReader, it can lead to an infinite stream, which can be used to mount a denial of service attack against services that use Compress' zip package.

Details

Denial of Service (DoS) describes a family of attacks, all aimed at making a system inaccessible to its intended and legitimate users.

Unlike other vulnerabilities, DoS attacks usually do not aim at breaching security. Rather, they are focused on making websites and services unavailable to genuine users resulting in downtime.

One popular Denial of Service vulnerability is DDoS (a Distributed Denial of Service), an attack that attempts to clog network pipes to the system by generating a large volume of traffic from many machines.

When it comes to open source libraries, DoS vulnerabilities allow attackers to trigger such a crash or crippling of the service by using a flaw either in the application code or from the use of open source libraries.

Two common types of DoS vulnerabilities:

  • High CPU/Memory Consumption- An attacker sending crafted requests that could cause the system to take a disproportionate amount of time to process. For example, commons-fileupload:commons-fileupload.

  • Crash - An attacker sending crafted requests that could cause the system to crash. For Example, npm ws package

Remediation

Upgrade org.apache.commons:commons-compress to version 1.18 or higher.

References

CVSS Score

5.5
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Credit
Tobias Ospelt
CVE
CVE-2018-11771
CWE
CWE-400
Snyk ID
SNYK-JAVA-ORGAPACHECOMMONS-32473
Disclosed
16 Aug, 2018
Published
19 Aug, 2018