Denial of Service (DoS)

Affecting org.apache.activemq:activemq-client artifact, versions [5.0.0, 5.14.5)

Do your applications use this vulnerable package? Test your applications

Overview

org.apache.activemq:activemq-client is a ActiveMQ Client implementation.

Affected versions of this package are vulnerable to Denial of Service (DoS). The client package exposed a remote shutdown command in the ActiveMQConnection class. An attacker could use this flaw to achieve denial of service on a client.

Remediation

Upgrade org.apache.activemq:activemq-client to version 5.14.5 or higher.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    Low
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Credit
Unknown
CVE
CVE-2015-7559
CWE
CWE-776
Snyk ID
SNYK-JAVA-ORGAPACHEACTIVEMQ-451539
Disclosed
18 Oct, 2016
Published
04 Jul, 2019