Cross-site Scripting (XSS)

Affecting github.com/argoproj/argo-cd/cmd package, versions <1.7.13 || >=1.8.0 <1.8.6

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Cross-site Scripting (XSS) the SSO provider connected to Argo CD would have to send back a malicious error message containing JavaScript to the user.

Remediation

Upgrade github.com/argoproj/argo-cd/cmd to version 1.7.13, 1.8.6 or higher.

References

CVSS Score

4.7
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    High
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L
Credit
jannfis
CVE
CVE-2021-23347
CWE
CWE-79
Snyk ID
SNYK-GOLANG-GITHUBCOMARGOPROJARGOCDCMD-1078291
Disclosed
22 Feb, 2021
Published
03 Mar, 2021