Arbitrary Code Injection

Affecting curl package, versions *

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Arbitrary Code Injection curl 7.20.0 through 7.70.0 is vulnerable to improper restriction of names for files and other resources that can lead too overwriting a local file when the -J flag is used.

Remediation

There is no fixed version for curl.

References

CVSS Score

7.1
high severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
CVE
CVE-2020-8177
CWE
CWE-74 CWE-99
Snyk ID
SNYK-DEBIAN10-CURL-573151
Disclosed
14 Dec, 2020
Published
24 Jun, 2020