eleventy-plugin-images-responsiver

v1.9.1

Global solution for responsive images in Eleventy, allowing authors to use Markdown syntax for image and yet get responsive images in generated HTML.

MIT
Latest version published 5 months ago
    npm install eleventy-plugin-images-responsiver
  

Package Health Score

69 / 100

Popularity

Limited

Weekly Downloads (271)

Download trend
Dependents
1
GitHub Stars
50
Forks
7
Contributors
6

Direct Usage Popularity


The npm package eleventy-plugin-images-responsiver receives a total of 271 downloads a week. As such, we scored eleventy-plugin-images-responsiver popularity level to be Limited.

Based on project statistics from the GitHub repository for the npm package eleventy-plugin-images-responsiver, we found that it has been starred 50 times, and that 1 other projects in the ecosystem are dependent on it.

Downloads are calculated as moving averages for a period of the last 12 months, excluding weekends and known missing data points.

Security

No known security issues
Powered by Snyk

Security and license risk for significant versions

All Versions
Popular

Version

Release Date

03/2020
03/2020
03/2020
06/2021
06/2021

Direct Vulnerabilities

0.3.0
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
0.4.0
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
0.5.0
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
1.8.4
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
Popular
1.9.1
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L

Indirect Vulnerabilities

0.3.0
0.4.0
0.5.0
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
1.8.4
Popular
1.9.1

License Risk

0.3.0
  • 0
    H
  • 0
    M
  • 0
    L
0.4.0
  • 0
    H
  • 0
    M
  • 0
    L
0.5.0
  • 0
    H
  • 0
    M
  • 0
    L
1.8.4
  • 0
    H
  • 0
    M
  • 0
    L
Popular
1.9.1
  • 0
    H
  • 0
    M
  • 0
    L
All security vulnerabilities belong to production dependencies of direct and indirect packages.

License
MIT

Security Policy
No

We found a way for you to contribute to the project! Looks like eleventy-plugin-images-responsiver is missing a security policy.


You can connect your project's repository to Snyk to stay up to date on security alerts and receive automatic fix pull requests.

    # Install the Snyk CLI and test your project
npm i snyk -g && snyk test eleventy-plugin-images-responsiver
Fix it in your project with Snyk!

Maintenance

Sustainable

Commit Frequency

Open Issues
21
Open PR
0
Last Release
5 months ago
Last Commit
7 days ago

Further analysis of the maintenance status of eleventy-plugin-images-responsiver based on released npm versions cadence, the repository activity, and other data points determined that its maintenance is Sustainable.

We found that eleventy-plugin-images-responsiver demonstrates a positive version release cadence with at least one new version released in the past 12 months.

As a healthy sign for on-going project maintenance, we found that the GitHub repository had at least 1 pull request or issue interacted with by the community.

Community

Sustainable
Readme.md
Yes
Contributing.md
Yes
Code of Conduct
Yes
Contributors
6
Funding
No

This project has seen only 10 or less contributors.


Embed Package Health Score Badge

package health: 69/100 package health 69/100

Package

Node.js Compatibility
not defined

Age
2 years
Dependencies
1 Direct
Versions
24
Install Size
6.33 kB
Dist-tags
1
# of Files
4
Maintainers
1
TS Typings
No

eleventy-plugin-images-responsiver has more than a single and default latest tag published for the npm package. This means, there may be other tags available for this package, such as next to indicate future releases, or stable to indicate stable releases.