perl vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the perl package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • L
Out-of-bounds Write
<5.22.1-9ubuntu0.9 Not available 01 Jun, 2020
  • L
Integer Overflow or Wraparound
<5.22.1-9ubuntu0.9 Not available 01 Jun, 2020
  • L
Buffer Overflow
<5.22.1-9ubuntu0.9 Not available 01 Jun, 2020
  • M
Out-of-bounds Read
<5.22.1-9ubuntu0.6 Not available 02 Dec, 2018
  • M
Out-of-Bounds
<5.22.1-9ubuntu0.6 Not available 02 Dec, 2018
  • M
Out-of-bounds Write
<5.22.1-9ubuntu0.6 Not available 02 Dec, 2018
  • M
Out-of-Bounds
<5.22.1-9ubuntu0.6 Not available 02 Dec, 2018
  • M
Link Following
<5.22.1-9ubuntu0.5 Not available 07 Jun, 2018
  • M
Out-of-bounds Write
<5.22.1-9ubuntu0.3 Not available 17 Apr, 2018
  • M
Out-of-bounds Read
<5.22.1-9ubuntu0.3 Not available 17 Apr, 2018
  • M
Out-of-bounds Write
<5.22.1-9ubuntu0.3 Not available 17 Apr, 2018
  • M
Out-of-Bounds
<5.22.1-9ubuntu0.2 Not available 19 Sep, 2017
  • M
Out-of-Bounds
<5.22.1-9ubuntu0.2 Not available 19 Sep, 2017
  • L
Race Condition
<5.22.1-9ubuntu0.3 Not available 01 Jun, 2017
  • L
Improper Access Control
<5.22.1-9ubuntu0.3 Not available 02 Aug, 2016