glibc vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the glibc package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • L
Out-of-bounds Read
* Not available 06 Jan, 2021
  • L
Loop with Unreachable Exit Condition ('Infinite Loop')
* Not available 06 Jan, 2021
  • L
Integer Underflow
* Not available 02 Apr, 2020
  • M
Out-of-bounds Write
<2.23-0ubuntu11.2 Not available 07 Mar, 2020
  • L
Use After Free
<2.23-0ubuntu11.2 Not available 07 Mar, 2020
  • L
Out-of-Bounds
<2.23-0ubuntu11.2 Not available 04 Mar, 2020
  • L
Information Exposure
<2.23-0ubuntu11.2 Not available 20 Nov, 2019
  • L
Out-of-bounds Read
<2.23-0ubuntu11.2 Not available 26 Feb, 2019
  • L
Improper Data Handling
* Not available 26 Feb, 2019
  • L
Improper Input Validation
* Not available 21 Jan, 2019
  • M
Out-of-bounds Write
<2.23-0ubuntu11.2 Not available 18 May, 2018
  • M
Out-of-Bounds
<2.23-0ubuntu11.2 Not available 18 May, 2018
  • M
Out-of-bounds Write
<2.23-0ubuntu11.2 Not available 18 May, 2018
  • M
Out-of-bounds Write
<2.23-0ubuntu11.2 Not available 01 Feb, 2018
  • L
Missing Release of Resource after Effective Lifetime
<2.23-0ubuntu10 Not available 01 Feb, 2018
  • L
Out-of-Bounds
<2.23-0ubuntu10 Not available 01 Feb, 2018
  • H
Out-of-bounds Write
<2.23-0ubuntu10 Not available 10 Jan, 2018
  • L
Untrusted Search Path
<2.23-0ubuntu10 Not available 18 Dec, 2017
  • L
Out-of-Bounds
<2.23-0ubuntu10 Not available 22 Oct, 2017
  • L
Out-of-Bounds
<2.23-0ubuntu10 Not available 20 Oct, 2017
  • L
Use After Free
<2.23-0ubuntu11.2 Not available 07 Sep, 2017
  • L
Allocation of Resources Without Limits or Throttling
* Not available 01 Aug, 2017
  • M
Out-of-Bounds
<2.23-0ubuntu9 Not available 19 Jun, 2017
  • L
Improper Data Handling
* Not available 20 Mar, 2017
  • L
Improper Input Validation
* Not available 02 Mar, 2017
  • L
Resource Management Errors
<2.23-0ubuntu6 Not available 17 Feb, 2017
  • L
Improper Access Control
<2.23-0ubuntu6 Not available 07 Oct, 2016
  • L
Out-of-bounds Write
<2.23-0ubuntu6 Not available 10 Jun, 2016
  • L
Improper Input Validation
<2.23-0ubuntu6 Not available 10 Jun, 2016
  • L
Out-of-Bounds
<2.23-0ubuntu6 Not available 01 Jun, 2016