ruby-jss vulnerabilities

The ruby-jss gem provides native ruby access to the REST APIs of Jamf Pro, an enterprise/education tool for managing Apple devices, from jamf.com. The JSS module provides access to the 'Classic' API, while the Jamf module provides access to the more modern 'Jamf Pro' API. Jamf Pro objects are implemented as classes and, within each module, can interact with each other. The underlying data transfer using JSON or XML is handled automatically under the hood to allow simpler, intuitive automation of Jamf-related Tasks.

Latest version: 1.6.4

Licenses detected

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the ruby-jss package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • H
Arbitrary Code Execution
<1.6.0 Not available 08 Oct, 2021
  • C
Arbitrary Code Execution
<1.6.0 Not available 26 May, 2021