xiongrui-httpserver vulnerabilities

This package is no longer supported and has been deprecated. To avoid malicious use, npm is hanging on to the package name.

Latest version 2.0.0
First published 4 years ago
Latest version published 2 years ago

Licenses detected

  • license: MIT >=1.0.0 <2.0.0
  • license: ISC >=2.0.0
Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the xiongrui-httpserver package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • H
Directory Traversal
* Not available 07 Jun, 2017
Versions
Version Published Licenses Direct Vulnerabilities
xiongrui-httpserver 2.0.0 Deprecated Latest 03 Aug, 2017 ISC
  • 1 H
  • 0 M
  • 0 L
xiongrui-httpserver 1.0.5 Deprecated 15 Apr, 2016 MIT
  • 1 H
  • 0 M
  • 0 L
xiongrui-httpserver 1.0.4 Deprecated 15 Apr, 2016 MIT
  • 1 H
  • 0 M
  • 0 L
xiongrui-httpserver 1.0.3 Deprecated 15 Apr, 2016 MIT
  • 1 H
  • 0 M
  • 0 L
xiongrui-httpserver 1.0.2 Deprecated 15 Apr, 2016 MIT
  • 1 H
  • 0 M
  • 0 L
xiongrui-httpserver 1.0.1 Deprecated 15 Apr, 2016 MIT
  • 1 H
  • 0 M
  • 0 L
xiongrui-httpserver 1.0.0 Deprecated 15 Apr, 2016 MIT
  • 1 H
  • 0 M
  • 0 L