SQL Injection

Affecting waterline-sequel package, versions <0.5.1

Do your applications use this vulnerable package? Test your applications

Overview

'waterline-sequel' is a helper library for generating SQL queries from the Waterline Query Language.

waterline-sequel version 0.5.0 is vulnerable to SQL Injection via like, contains, startsWith or endsWith methods.

Remediation

Upgrade waterline-sequel to version 0.5.1 or greater

References

CVSS Score

8.2
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Credit
James Hush
CVE
CVE-2016-10551
CWE
CWE-89
Snyk ID
npm:waterline-sequel:20160804
Disclosed
04 Aug, 2016
Published
31 Oct, 2016