Information Exposure

Affecting serve-static package, versions <0.0.0

Do your applications use this vulnerable package? Test your applications

Overview

Amendment

This was deemed not a vulnerability.

Overview

serve-static is a Node.js module available through the npm registry.

Affected versions of this package are vulnerable to Information Exposure. The roots path would be exposed via the express.static, res.sendfile, and res.sendFile methods.

Recommendations

Upgrade serve-static to version 1.8.1 or higher.

References

CVSS Score

3.7
low severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
Credit
Unknown
CWE
CWE-211
Snyk ID
npm:serve-static:20150120
Disclosed
20 Jan, 2015
Published
20 Jan, 2015