public vulnerabilities

Run http server hosting static files with specified public dir & port

Latest version 0.1.5
First published 8 years ago
Latest version published 2 months ago

Licenses detected

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the public package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • M
Path Traversal
<0.1.3 Not available 28 Aug, 2019
  • L
Cross-site Scripting (XSS)
<0.1.4 Not available 17 Apr, 2018
  • H
Directory Traversal
<0.1.3 Not available 21 Feb, 2018
Versions
Version Published Licenses Direct Vulnerabilities
public 0.1.5 Deprecated Latest 22 Jul, 2019 Unknown
  • 0 H
  • 0 M
  • 0 L
public 0.1.4 Deprecated 07 Jun, 2018 Unknown
  • 0 H
  • 0 M
  • 0 L
public 0.1.3 Deprecated 15 Feb, 2018 Unknown
  • 0 H
  • 0 M
  • 1 L
public 0.1.2 Deprecated 08 Mar, 2012 Unknown
  • 1 H
  • 1 M
  • 1 L
public 0.1.1 Deprecated 22 Nov, 2011 Unknown
  • 1 H
  • 1 M
  • 1 L
public 0.1.0 Deprecated 01 Oct, 2011 Unknown
  • 1 H
  • 1 M
  • 1 L