User Impersonation

Affecting passport-wsfed-saml2 package, versions <3.0.5

high severity

Overview

passport-wsfed-saml2 is a ws-federation protocol + SAML2 tokens authentication provider for Passport.

Affected versons if thus package are vulnerable to User Impersonation. A vulnerability has been discovered in the Auth0 passport-wsfed-saml2 library affecting versions < 3.0.5. This vulnerability allows an attacker to impersonate another user and potentially elevate their privileges if the SAML identity provider does not sign the full SAML response (e.g., only signs the assertion within the response).

Remediation

Upgrade passport-wsfed-saml2 to version 3.0.5 or higher.

References

Do your applications use this vulnerable package?

Credit
Alan Bishop
CVE
CVE-2017-16897
CWE
CWE-269
Snyk ID
npm:passport-wsfed-saml2:20171222
Disclosed
22 Dec, 2017
Published
03 Jan, 2018