Arbitrary Code Injection

Affecting mongoosify package, versions <0.0.4

Do your applications use this vulnerable package? Test your applications

Overview

mongoosify is a prototype-based inheritance library that makes it easy to create objects and inheritance hierarchies without losing the power of javascript's prototype system.

Affected versions of the package are vulnerable to Arbitrary Code Injection due to unsafe use of the eval() function. Node.js provides the eval() function by default, and is used to translate strings into Javascript code. An attacker can craft a malicious payload to inject arbitrary commands.

Remediation

Upgrade mongoosify to version 0.0.4 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Credit
Cristian-Alexandru Staicu, Michael Pradel, Ben Livshits
CWE
CWE-94
Snyk ID
npm:mongoosify:20160408
Disclosed
08 Apr, 2016
Published
01 May, 2017