Heap-based Buffer Overflow

Affecting libyaml package, versions <0.2.3

Do your applications use this vulnerable package? Test your applications

Overview

LibYAML, the library that libyaml provides bindings for is vulnerable to a heap-based buffer overflow when parsing YAML tags.

Source: Node Security Project

Remediation

Update to version 0.2.3 that includes a version of LibYAML that contains a fix for this issue.

References

CVSS Score

8.6
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H
Credit
N/A
CVE
CVE-2013-6393
CWE
CWE-680
Snyk ID
npm:libyaml:20140204
Disclosed
04 Feb, 2014
Published
04 Feb, 2014