LDAP Injection

Affecting ldapauth package, versions <=2.2.4

Do your applications use this vulnerable package? Test your applications

Overview

ldapauth versions <= 2.2.4 are vulnerable to ldap injection through the username parameter.

Source: Node Security Project

Remediation

Consider updating to use ldapauth-fork 2.3.3 or greater as ldapauth has not yet been patched.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Credit
David Black, Jerome Touffe-Blin
CWE
CWE-90
Snyk ID
npm:ldapauth:20150918
Disclosed
18 Sep, 2015
Published
18 Sep, 2015