Cross-site Request Forgery (CSRF)

Affecting keystone package, versions <0.2.34

Do your applications use this vulnerable package? Test your applications

Overview

keystone is a web Application Framework and Admin GUI / Content Management System built on Express.js and Mongoose.

Affected versions of the package are vulnerable to Cross-site Request Forgery (CSRF).

Remediation

Upgrade keystone to version 0.2.34 or higher.

References

CVSS Score

6.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Credit
Mickael van der Beek
CWE
CWE-352
Snyk ID
npm:keystone:20141129
Disclosed
28 Nov, 2014
Published
25 Dec, 2017