jquery vulnerabilities

JavaScript library for DOM operations

Latest version: 3.2.1

View on npm

Licenses detected

  • license: Unknown >=1.5.1 <1.7.2
  • license: MIT >=1.7.2 <1.9.1,>=1.9.1 <1.11.0-beta3,>=1.11.0-beta3 <1.11.0-rc1,>=1.11.0-rc1 <1.11.0,>=1.11.0 <1.11.1-beta1,>=1.11.1-beta1 <1.11.1-rc1,>=1.11.1-rc1 <1.11.1-rc2,>=1.11.1-rc2 <1.11.1,>=1.11.1 <1.11.2,>=1.11.2 <1.11.3,>=1.11.3 <1.12.0,>=1.12.0 <2.1.0-beta2,>=2.1.0-beta2 <2.1.0-beta3,>=2.1.0-beta3 <2.1.0-rc1,>=2.1.0-rc1 <2.1.0,>=2.1.0 <2.1.1-beta1,>=2.1.1-beta1 <2.1.1-rc1,>=2.1.1-rc1 <2.1.1-rc2,>=2.1.1-rc2 <2.1.1,>=2.1.1 <2.1.2,>=2.1.2 <2.1.3,>=2.1.3 <2.1.4,>=2.1.4 <2.2.0,>=2.2.0
Vulnerability Vulnerable versions Snyk patch Published
  • L
Denial of Service (DoS)
<3.0.0 >=2.1.0-beta1 Not available 26 Dec, 2016
  • M
Cross-site Scripting (XSS)
<3.0.0-beta1 >1.12.3 || <1.12.0 >=1.4.0 Not available 27 Nov, 2016
  • M
DOM Based Cross-site Scripting (XSS)
<=1.5.1 >=1.4.2 Not available 20 Oct, 2016
  • M
Cross-site Scripting (XSS)
<1.9.0 >=1.7.1 Not available 20 Oct, 2016
  • M
Cross-site Scripting (XSS)
<1.6.3 Not available 20 Oct, 2016

Find out if you have vulnerabilities that put you at risk.

Test your code