Authentication Bypass

Affecting ghost package, versions <0.5.9

Do your applications use this vulnerable package? Test your applications

Overview

ghost is a blogging platform. Affected versions of the package are vulnerable to Authentication Bypass. An authenticated user can spoof an HTTP GET request with any username to access any other users’ drafts. This is due to the user parameter not being validated upon the request.

Remediation

Upgrade ghost to version 0.5.9 or higher.

References

CVSS Score

5.3
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Credit
Matteo Beccaro
CVE
CVE-2015-1409
CWE
CWE-285
Snyk ID
npm:ghost:20150303-4
Disclosed
02 Mar, 2015
Published
30 May, 2017