Arbitrary Code Execution

Affecting electron package, versions >=1.7.0 <1.7.16 || >=1.8.0 <1.8.8 || >=2.0.0 <2.0.8 || >=3.0.0-beta6 <3.0.0-beta.7

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Arbitrary Code Execution. Note: This vulnerability affects only users who embed any remote user content, even in a sandbox and accept user input with any XSS vulnerabilities.

Remediation

Upgrade electron to version 1.7.16, 1.8.8, 2.0.8, 3.0.0-beta.7 or higher.

References

CVSS Score

9.8
critical severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C
Credit
Matt Austin
CVE
CVE-2018-15685
CWE
CWE-94
Snyk ID
npm:electron:20180822
Disclosed
22 Aug, 2018
Published
27 Aug, 2018