Arbitrary Code Execution

Affecting electron package, versions <1.6.14 || >=1.7.0 <1.7.8 || >=1.8.0 <1.8.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS.

Affected versions of this package are vulnerable to Arbitrary Code Execution. An arbitrary code execution vulnerability was discovered in Google Chromium, affecting many versions of Electron. Any Electron app that accesses remote content is vulnerable to this exploit, regardless of whether the sandbox option is enabled.

Remediation

Upgrade electron to version 1.6.14, 1.7.8, 1.8.1 or higher.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
Electron Team
CVE
CVE-2017-16151
CWE
CWE-94
Snyk ID
npm:electron:20170927
Disclosed
26 Sep, 2017
Published
28 Sep, 2017