datatables vulnerabilities

DataTables enhances HTML tables with the ability to sort, filter and page the data in the table very easily. It provides a comprehensive API and set of configuration options, allowing you to consume data from virtually any data source.

Latest version 1.10.18
First published 5 years ago
Latest version published a year ago

Licenses detected

  • license: MIT >=0
Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the datatables package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • M
Cross-site Scripting (XSS)
<1.10.10 >=1.10.1 Not available 08 May, 2017
  • M
Cross-site Scripting (XSS)
<1.10.10 Not available 18 Sep, 2015
Versions
Version Published Licenses Direct Vulnerabilities
datatables 1.10.18 Latest 20 Jun, 2018 MIT
  • 0 H
  • 0 M
  • 0 L
datatables 1.10.17 14 Jun, 2018 MIT
  • 0 H
  • 0 M
  • 0 L
datatables 1.10.13 06 Dec, 2016 MIT
  • 0 H
  • 0 M
  • 0 L
datatables 1.10.12 23 May, 2016 MIT
  • 0 H
  • 0 M
  • 0 L
datatables 1.10.11 Deprecated 29 Feb, 2016 MIT
  • 0 H
  • 0 M
  • 0 L
datatables 1.10.12-dev Pre-release 29 Feb, 2016 MIT
  • 0 H
  • 0 M
  • 0 L
datatables 1.10.9 Deprecated 21 Sep, 2015 MIT
  • 0 H
  • 2 M
  • 0 L
datatables 1.10.8 Deprecated 20 Aug, 2015 MIT
  • 0 H
  • 2 M
  • 0 L
datatables 1.10.7 Deprecated 30 Apr, 2015 MIT
  • 0 H
  • 2 M
  • 0 L
datatables 1.10.6 Deprecated 03 Apr, 2015 MIT
  • 0 H
  • 2 M
  • 0 L
datatables 1.10.5 Deprecated 10 Feb, 2015 MIT
  • 0 H
  • 2 M
  • 0 L
datatables 1.10.5-dev Pre-release 13 Nov, 2014 MIT
  • 0 H
  • 2 M
  • 0 L