Sandbox Bypass

Affecting constantinople package, versions <3.1.1

Do your applications use this vulnerable package? Test your applications

Overview

constantinople determines whether a JavaScript expression evaluates to a constant (using acorn).

Affected versions of this package are vulnerable to a sandbox bypass which can lead to arbitrary code execution.

Remediation

Upgrade constantinople to version 3.1.1 or higher.

References

CVSS Score

10.0
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Changed
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
Credit
Mike Samuel
CWE
CWE-264
Snyk ID
npm:constantinople:20180421
Disclosed
21 Apr, 2018
Published
09 May, 2018