git vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the git package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • H
CVE-2021-40330
* Not available 31 Aug, 2021
  • H
Link Following
* Not available 10 Mar, 2021
  • H
Insufficiently Protected Credentials
<1:2.11.0-3+deb9u7 Not available 20 Apr, 2020
  • H
Insufficiently Protected Credentials
<1:2.11.0-3+deb9u6 Not available 14 Apr, 2020
  • C
CVE-2019-1353
<1:2.11.0-3+deb9u5 Not available 10 Dec, 2019
  • L
Use of Incorrectly-Resolved Name or Reference
* Not available 10 Dec, 2019
  • H
Improper Input Validation
<1:2.11.0-3+deb9u5 Not available 10 Dec, 2019
  • L
Improper Input Validation
* Not available 10 Dec, 2019
  • H
Improper Input Validation
<1:2.11.0-3+deb9u5 Not available 10 Dec, 2019
  • H
Improper Input Validation
<1:2.11.0-3+deb9u5 Not available 10 Dec, 2019
  • L
Improper Input Validation
<1:2.11.0-3+deb9u5 Not available 10 Dec, 2019
  • L
Improper Input Validation
* Not available 10 Dec, 2019
  • C
Arbitrary Argument Injection
<1:2.11.0-3+deb9u4 Not available 06 Oct, 2018
  • C
Improper Input Validation
<1:2.1.4-1 Not available 27 Jun, 2018
  • H
Out-of-bounds Read
<1:2.11.0-3+deb9u3 Not available 30 May, 2018
  • H
Directory Traversal
<1:2.11.0-3+deb9u3 Not available 30 May, 2018
  • L
Improper Input Validation
* Not available 09 Feb, 2018
  • L
Resource Exhaustion
* Not available 14 Oct, 2017
  • H
Open Redirect
<1:2.11.0-3+deb9u1 Not available 05 Oct, 2017
  • H
OS Command Injection
<1:2.11.0-3+deb9u2 Not available 29 Sep, 2017
  • H
Access Restriction Bypass
<1:2.11.0-3 Not available 01 Jun, 2017
  • H
Improper Encoding or Escaping of Output
<1:2.0.0~rc2-1 Not available 20 Mar, 2017
  • C
Improper Input Validation
<1:2.6.1-1 Not available 13 Apr, 2016
  • C
Out-of-Bounds
<1:2.8.0~rc3-1 Not available 08 Apr, 2016
  • C
Out-of-Bounds
<1:2.7.0-1 Not available 08 Apr, 2016
  • M
Cross-site Scripting (XSS)
<1:1.7.2.3-2.2 Not available 17 Dec, 2010