expat vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the expat package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • H
Out-of-bounds Read
<2.2.0-2+deb9u3 Not available 04 Sep, 2019
  • H
XML External Entity (XXE) Injection
<2.2.0-2+deb9u2 Not available 24 Jun, 2019
  • H
Integer Overflow or Wraparound
<2.2.0-2 Not available 11 Jun, 2018
  • H
XML External Entity (XXE) Injection
<2.2.0-2+deb9u1 Not available 25 Jul, 2017
  • H
Out-of-Bounds
<2.1.1-2 Not available 30 Jun, 2016
  • M
Cryptographic Issues
<2.1.1-3 Not available 16 Jun, 2016
  • H
Resource Management Errors
<2.1.1-3 Not available 16 Jun, 2016
  • H
Out-of-Bounds
<2.1.1-2 Not available 26 May, 2016
  • M
Numeric Errors
<2.1.0-7 Not available 23 Jul, 2015
  • L
Access Restriction Bypass
* Not available 21 Jan, 2014
  • M
Resource Management Errors
<2.1.0~beta3-1 Not available 03 Jul, 2012
  • M
Resource Management Errors
<2.1.0~beta3-1 Not available 03 Jul, 2012
  • L
Out-of-Bounds
<2.0.1-6 Not available 04 Dec, 2009
  • L
CVE-2009-3720
<2.0.1-5 Not available 03 Nov, 2009