cups vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the cups package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • M
Improper Input Validation
* Not available 03 Feb, 2021
  • L
Buffer Overflow
<2.2.1-8+deb9u6 Not available 25 Apr, 2020
  • H
Out-of-Bounds
<2.2.1-8+deb9u6 Not available 22 Apr, 2020
  • M
Out-of-bounds Read
<2.2.1-8+deb9u5 Not available 10 Dec, 2019
  • M
Out-of-bounds Read
<2.2.1-8+deb9u4 Not available 16 Sep, 2019
  • H
Buffer Overflow
<2.2.1-8+deb9u4 Not available 17 Aug, 2019
  • H
Buffer Overflow
<2.2.1-8+deb9u4 Not available 17 Aug, 2019
  • M
Information Exposure
<2.2.1-8+deb9u3 Not available 05 Aug, 2019
  • H
Access Restriction Bypass
<2.2.1-8+deb9u2 Not available 22 Jul, 2018
  • H
Improper Authorization
<2.2.1-8+deb9u2 Not available 22 Jul, 2018
  • M
Improper Authorization
<2.2.1-8+deb9u2 Not available 22 Jul, 2018
  • M
Improper Input Validation
<2.2.1-8+deb9u3 Not available 26 Mar, 2018
  • H
Authentication Bypass
<2.2.1-8+deb9u1 Not available 16 Feb, 2018
  • H
CRLF Injection
<2.2.1-8+deb9u2 Not available 07 Feb, 2018
  • L
Improper Input Validation
* Not available 12 Jan, 2018
  • H
Numeric Errors
<1.5.0-16 Not available 14 Jul, 2015
  • H
Out-of-Bounds
<1.5.0-16 Not available 14 Jul, 2015
  • H
Security Features
<1.7.5-12 Not available 26 Jun, 2015
  • M
Cross-site Scripting (XSS)
<1.7.5-12 Not available 26 Jun, 2015
  • M
Out-of-Bounds
<1.7.5-11 Not available 19 Feb, 2015
  • L
Link Following
<1.7.4-2 Not available 29 Jul, 2014
  • M
Access Restriction Bypass
<1.7.4-2 Not available 29 Jul, 2014
  • L
Link Following
<1.7.4-2 Not available 29 Jul, 2014
  • L
Link Following
<1.7.4-1 Not available 23 Jul, 2014
  • M
Cross-site Scripting (XSS)
<1.7.2-1 Not available 18 Apr, 2014
  • M
Access Restriction Bypass
<1.5.0-16 Not available 14 Mar, 2014
  • M
Numeric Errors
<1.5.0-16 Not available 14 Mar, 2014
  • M
Out-of-Bounds
<1.5.0-16 Not available 14 Mar, 2014
  • L
Link Following
<1.7.1-1 Not available 26 Jan, 2014
  • H
Access Restriction Bypass
<1.5.3-2.7 Not available 20 Nov, 2012