apt vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the apt package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • M
Integer Overflow or Wraparound
<1.4.11 Not available 10 Dec, 2020
  • M
Improper Input Validation
<1.4.10 Not available 12 May, 2020
  • H
Arbitrary Code Injection
<1.4.9 Not available 28 Jan, 2019
  • L
Improper Verification of Cryptographic Signature
* Not available 27 Jun, 2018
  • M
Improper Certificate Validation
<1.4~beta2 Not available 05 Dec, 2017
  • H
Improper Input Validation
<1.0.9 Not available 03 Nov, 2014
  • H
CVE-2014-0487
<1.0.9 Not available 03 Nov, 2014
  • M
Improper Input Validation
<1.0.9 Not available 03 Nov, 2014
  • H
Improper Input Validation
<0.9.12 Not available 03 Nov, 2014
  • M
Link Following
<1.0.9.2 Not available 15 Oct, 2014
  • M
Out-of-Bounds
<1.0.3 Not available 30 Sep, 2014
  • M
Improper Input Validation
<1.0.4 Not available 17 Jun, 2014
  • M
Access Restriction Bypass
<0.8.15.10 Not available 15 Apr, 2014
  • L
Information Exposure
<0.8.11 Not available 01 Mar, 2014
  • M
Improper Input Validation
<0.9.7.8 Not available 21 Mar, 2013
  • M
Information Exposure
<0.9.7.7 Not available 26 Dec, 2012
  • L
Improper Input Validation
<0.7.25 Not available 19 Jun, 2012
  • L
Improper Input Validation
<0.7.25 Not available 19 Jun, 2012
  • M
Improper Input Validation
<0.8.15.2 Not available 27 Jul, 2011
  • H
CVE-2009-1358
<0.7.21 Not available 21 Apr, 2009
  • H
Improper Input Validation
<0.7.21 Not available 16 Apr, 2009