sudo vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the sudo package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • H
Off-by-one Error
<1.8.27-1+deb10u3 Not available 27 Jan, 2021
  • L
Link Following
* Not available 12 Jan, 2021
  • L
Link Following
* Not available 12 Jan, 2021
  • H
Out-of-bounds Write
<1.8.27-1+deb10u2 Not available 30 Jan, 2020
  • L
CVE-2019-19234
* Not available 22 Dec, 2019
  • L
CVE-2019-19232
* Not available 22 Dec, 2019
  • H
Improper Handling of Exceptional Conditions
<1.8.27-1+deb10u1 Not available 14 Oct, 2019
  • L
Improper Input Validation
<1.7.4p4 Not available 27 Jun, 2018
  • H
Arbitrary Command Injection
<1.8.18p1-1 Not available 29 May, 2018
  • H
Race Condition
<1.8.17p1-1 Not available 10 Oct, 2017
  • H
Improper Input Validation
<1.8.19p1-2.1 Not available 05 Jun, 2017
  • M
Race Condition
<1.8.19p1-2 Not available 05 Jun, 2017
  • L
Information Exposure
<1.8.12-1 Not available 24 Apr, 2017
  • H
Improper Access Control
<1.8.15-1 Not available 14 Apr, 2017
  • H
Access Restriction Bypass
<1.8.15-1.1 Not available 17 Nov, 2015
  • L
Improper Input Validation
<1.8.5p2-1 Not available 11 Mar, 2014
  • M
Access Restriction Bypass
<1.8.5p2-1+nmu1 Not available 08 Apr, 2013
  • M
Access Restriction Bypass
<1.8.5p2-1+nmu1 Not available 08 Apr, 2013
  • M
Access Restriction Bypass
<1.8.5p2-1+nmu1 Not available 08 Apr, 2013
  • H
Access Restriction Bypass
<1.8.5p2-1+nmu1 Not available 05 Mar, 2013
  • H
Access Restriction Bypass
<1.8.3p2-1.1 Not available 18 May, 2012
  • H
Use of Externally-Controlled Format String
<1.8.3p2-1 Not available 01 Feb, 2012
  • M
Access Restriction Bypass
<1.7.4p4-6 Not available 18 Jan, 2011
  • H
CVE-2010-2956
<1.7.4p4-1 Not available 10 Sep, 2010
  • H
Access Restriction Bypass
<1.7.2p7-1 Not available 07 Jun, 2010
  • H
Improper Input Validation
<1.7.2p6-1 Not available 16 Apr, 2010
  • M
Access Restriction Bypass
<1.7.0-1 Not available 25 Feb, 2010
  • H
Access Restriction Bypass
<1.7.2p1-1.2 Not available 24 Feb, 2010
  • M
Access Restriction Bypass
<1.6.9p17-2 Not available 30 Jan, 2009
  • M
Credentials Management
<1.6.9p12-1 Not available 07 Jul, 2008