openssl vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the openssl package. This does not include vulnerabilities belonging to this package’s dependencies.

Vulnerability Vulnerable versions Snyk patch Published
  • H
Denial of Service (DoS)
>=1.0.1, <1.0.109,>=1.0.204.1, <1.0.211 Not available 27 Nov, 2019
  • M
Information Exposure
<1.0.109,>=1.0.2, <1.0.2.110 Not available 02 Oct, 2019
  • M
Information Exposure
>=1.0.1, <1.0.200,>=1.0.204.1, <1.0.207 Not available 02 Oct, 2019
  • H
Out-of-bounds Read
>=1.0.2, <1.0.209 Not available 02 Oct, 2019
  • L
Cryptographic Issues
>=1.0.0 Not available 02 Oct, 2019
  • H
Resource Management Errors
>=1.0.1, <1.0.200,>=1.0.204.1, <1.0.208 Not available 02 Oct, 2019
  • M
Information Exposure
>=1.0.1, <1.0.200,>=1.0.204.1, <1.0.210 Not available 02 Oct, 2019
  • L
Improper Input Validation
>=1.0.200 Not available 02 Oct, 2019
  • L
Information Exposure
>=1.0.1, <1.0.200,>=1.0.204.1, <1.0.206 Not available 02 Oct, 2019
  • L
Cryptographic Issues
>=1.0.0 Not available 02 Oct, 2019
  • M
Key Management Errors
>=1.0.200, <1.0.211 Not available 02 Oct, 2019
  • M
Information Exposure
>=1.0.0, <1.0.211 Not available 02 Oct, 2019
  • M
Key Management Errors
>=1.0.200, <1.0.211 Not available 02 Oct, 2019
  • M
Cryptographic Issues
>=1.0.200, <1.0.208 Not available 02 Oct, 2019
  • H
Out-of-Bounds
>=1.0.1, <1.0.200,>=1.0.204.1, <1.0.208 Not available 02 Oct, 2019
  • M
Information Exposure
>=1.0.200, <1.0.211 Not available 02 Oct, 2019
  • H
Numeric Errors
>=1.0.1, <1.0.200,>=1.0.204.1, <1.0.209 Not available 02 Oct, 2019
  • M
Denial Of Service (DoS) Through Null Pointer Dereference
>=1.0.1, <1.0.109 Not available 02 Oct, 2019
  • M
Cryptographic Issues
>=1.0.0, <1.0.110 Not available 02 Oct, 2019
  • M
Resource Management Errors
>=1.0.0, <1.0.108 Not available 02 Oct, 2019
  • M
Denial Of Service (DoS) Through Null Pointer Dereference
>=1.0.0, <1.0.108 Not available 02 Oct, 2019
  • M
Cryptographic Issues
>=1.0.0, <1.0.111 Not available 02 Oct, 2019
  • M
Denial Of Service (DoS) Through Null Pointer Dereference
>=1.0.200 Not available 02 Oct, 2019
  • M
Cryptographic Issues
>=1.0.200, <1.0.206 Not available 02 Oct, 2019
  • M
Cryptographic Issues
>=1.0.0, <1.0.110 Not available 02 Oct, 2019
  • M
Improper Input Validation
>=1.0.1 Not available 02 Oct, 2019
  • M
Cryptographic Issues
>=1.0.0, <1.0.110 Not available 02 Oct, 2019
  • M
Improper Input Validation
>=1.0.1 Not available 02 Oct, 2019
  • M
Information Exposure
>=1.0.200, <1.0.211 Not available 02 Oct, 2019
  • M
Resource Exhaustion
>=1.0.202, <1.0.211 Not available 02 Oct, 2019