openssl vulnerabilities

Continuously find & fix vulnerabilities like these in your dependencies. Test and protect your applications

Direct Vulnerabilities

Known vulnerabilities in the openssl package. This does not include vulnerabilities belonging to this package’s dependencies.

Report new vulnerabilities
Vulnerability Vulnerable versions Snyk patch Published
  • H
Out-of-bounds Read
<1.1.1l-r0 Not available 25 Aug, 2021
  • C
Buffer Overflow
<1.1.1l-r0 Not available 25 Aug, 2021
  • H
Improper Certificate Validation
<1.1.1k-r0 Not available 26 Mar, 2021
  • M
NULL Pointer Dereference
<1.1.1k-r0 Not available 26 Mar, 2021
  • L
Inadequate Encryption Strength
<1.1.1j-r0 Not available 17 Feb, 2021
  • H
Integer Overflow or Wraparound
<1.1.1j-r0 Not available 17 Feb, 2021
  • M
Integer Overflow or Wraparound
<1.1.1j-r0 Not available 17 Feb, 2021
  • M
NULL Pointer Dereference
<1.1.1i-r0 Not available 12 Dec, 2020
  • H
NULL Pointer Dereference
<1.1.1g-r0 Not available 21 Jul, 2020
  • M
Information Exposure
<1.1.1d-r3 Not available 06 Dec, 2019
  • L
Use of a Broken or Risky Cryptographic Algorithm
<1.1.1d-r1 Not available 11 Sep, 2019
  • M
Use of Insufficiently Random Values
<1.1.1d-r1 Not available 11 Sep, 2019
  • M
Missing Encryption of Sensitive Data
<1.1.1d-r1 Not available 11 Sep, 2019
  • H
Use of a Broken or Risky Cryptographic Algorithm
<1.1.1b-r1 Not available 06 Mar, 2019
  • M
Use of a Broken or Risky Cryptographic Algorithm
<1.1.1a-r0 Not available 02 Dec, 2018
  • M
Use of a Broken or Risky Cryptographic Algorithm
<1.1.1a-r0 Not available 02 Dec, 2018