Improper Certificate Validation

Affecting node package, versions [15.0.0,15.14.0) || [13.0.0,14.16.1) || [12.0.0,12.22.1) || [,10.24.1)

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

node is a JavaScript runtime built on Chrome's V8 JavaScript engine.

Affected versions of this package are vulnerable to Improper Certificate Validation. There is insufficient verification of a certificate chain when using the X509_V_FLAG_X509_STRICT flag.

Remediation

Upgrade node to version 15.14.0, 14.16.1, 12.22.1, 10.24.1 or higher.

References

CVSS Score

7.4
high severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Credit
Xiang Ding
CVE
CVE-2021-3450
CWE
CWE-295
Snyk ID
SNYK-UPSTREAM-NODE-1243765
Published
07 Apr, 2021