Incorrect Default Permissions

Affecting libzstd package, versions <1.3.3+dfsg-2ubuntu1.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Affected versions of this package are vulnerable to Incorrect Default Permissions. In the Zstandard command-line utility prior to v1.4.1, output files were created with default permissions. Correct file permissions (matching the input) would only be set at completion time. Output files could therefore be readable or writable to unintended parties.

Remediation

Upgrade libzstd to version or higher.

References

CVSS Score

5.5
medium severity
  • Attack Vector
    Local
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVE
CVE-2021-24031
CWE
CWE-276 CWE-277
Snyk ID
SNYK-UBUNTU1804-LIBZSTD-1082293
Disclosed
04 Mar, 2021
Published
04 Mar, 2021