Improper Input Validation

Affecting iptables package, versions *

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

extensions/libxt_tcp.c in iptables through 1.4.21 does not match TCP SYN+FIN packets in --syn rules, which might allow remote attackers to bypass intended firewall restrictions via crafted packets. NOTE: the CVE-2012-6638 fix makes this issue less relevant.

References

CVSS Score

7.3
low severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVE
CVE-2012-2663
Snyk ID
SNYK-UBUNTU1804-IPTABLES-287327
Disclosed
15 Feb, 2014
Published
15 Feb, 2014