Double Free

Affecting gnutls28 package, versions <3.5.18-1ubuntu1.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

A vulnerability was found in gnutls versions from 3.5.8 before 3.6.7. A memory corruption (double free) vulnerability in the certificate verification API. Any client or server application that verifies X.509 certificates with GnuTLS 3.5.8 or later is affected.

References

CVSS Score

7.5
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE
CVE-2019-3829
CWE
CWE-415 CWE-416
Snyk ID
SNYK-UBUNTU1804-GNUTLS28-341642
Disclosed
27 Mar, 2019
Published
27 Mar, 2019