Out-of-Bounds

Affecting curl package, versions <7.58.0-2ubuntu3.5

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Curl versions 7.33.0 through 7.61.1 are vulnerable to a buffer overrun in the SASL authentication code that may lead to denial of service.

References

CVSS Score

9.8
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2018-16839
CWE
CWE-119 CWE-122 CWE-190
Snyk ID
SNYK-UBUNTU1804-CURL-358502
Disclosed
31 Oct, 2018
Published
02 Dec, 2018