SQL Injection

Affecting python-django package, versions <1.8.7-1ubuntu5.12

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream python-django package. See Remediation section below for Ubuntu:16.04 relevant versions.

Django 1.11 before 1.11.29, 2.2 before 2.2.11, and 3.0 before 3.0.4 allows SQL Injection if untrusted data is used as a tolerance parameter in GIS functions and aggregates on Oracle. By passing a suitably crafted tolerance to GIS functions and aggregates on Oracle, it was possible to break escaping and inject malicious SQL.

Remediation

Upgrade Ubuntu:16.04 python-django to version 1.8.7-1ubuntu5.12 or higher.

References

CVSS Score

8.8
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    Low
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2020-9402
CWE
CWE-89
Snyk ID
SNYK-UBUNTU1604-PYTHONDJANGO-559162
Disclosed
05 Mar, 2020
Published
04 Mar, 2020