Cross-site Scripting (XSS)

Affecting python-django package, versions <1.8.7-1ubuntu5.1

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

NVD Description

Note: Versions mentioned in the description apply to the upstream python-django package. See Remediation section below for Ubuntu:16.04 relevant versions.

Cross-site scripting (XSS) vulnerability in the dismissChangeRelatedObjectPopup function in contrib/admin/static/admin/js/admin/RelatedObjectLookups.js in Django before 1.8.14, 1.9.x before 1.9.8, and 1.10.x before 1.10rc1 allows remote attackers to inject arbitrary web script or HTML via vectors involving unsafe usage of Element.innerHTML.

Remediation

Upgrade Ubuntu:16.04 python-django to version 1.8.7-1ubuntu5.1 or higher.

References

CVSS Score

6.1
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Changed
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:F
CVE
CVE-2016-6186
CWE
CWE-79
Snyk ID
SNYK-UBUNTU1604-PYTHONDJANGO-361051
Disclosed
05 Aug, 2016
Published
05 Aug, 2016