Improper Input Validation

Affecting libxrender package, versions *

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

Multiple buffer overflows in the (1) XvQueryAdaptors and (2) XvQueryEncodings functions in X.org libXrender before 0.9.10 allow remote X servers to trigger out-of-bounds write operations via vectors involving length fields.

References

CVSS Score

9.8
low severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE
CVE-2016-7949
CWE
CWE-20 CWE-787
Snyk ID
SNYK-UBUNTU1604-LIBXRENDER-286052
Disclosed
13 Dec, 2016
Published
13 Dec, 2016