Cryptographic Issues

Affecting gnupg package, versions <1.4.20-1ubuntu3.3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

libgcrypt before version 1.7.8 is vulnerable to a cache side-channel attack resulting into a complete break of RSA-1024 while using the left-to-right method for computing the sliding-window expansion. The same attack is believed to work on RSA-2048 with moderately more computation. This side-channel requires that attacker can run arbitrary software on the hardware where the private RSA key is used.

References

CVSS Score

6.8
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    High
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Changed
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    None
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
CVE
CVE-2017-7526
CWE
CWE-200 CWE-310
Snyk ID
SNYK-UBUNTU1604-GNUPG-340541
Disclosed
26 Jul, 2018
Published
27 Jun, 2018