Out-of-bounds Read

Affecting curl package, versions <7.47.0-1ubuntu2.8

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126: Buffer Over-read vulnerability in denial of service that can result in curl can be tricked into reading data beyond the end of a heap based buffer used to store downloaded RTSP content.. This vulnerability appears to have been fixed in curl < 7.20.0 and curl >= 7.60.0.

References

CVSS Score

9.1
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
CVE
CVE-2018-1000301
CWE
CWE-125
Snyk ID
SNYK-UBUNTU1604-CURL-358723
Disclosed
24 May, 2018
Published
24 May, 2018