Privilege Escalation

Affecting solidus_backend gem, versions <1.1.0.pre2

medium severity

Overview

solidus_backend is Admin interface for the Solidus e-commerce framework.

Affected versions of the package are vulnerable to Privilege Escalation. A lower-level admin can change the email address of a higher-level admin to an email address they have access to, and as a result they will gain access to the admin's permissions.

Remediation

Upgrade solidus_backend to version 1.1.0.pre2 or higher.

References

Do your applications use this vulnerable package?

Credit
Andrew Thal
CWE
CWE-264
Snyk ID
SNYK-RUBY-SOLIDUSBACKEND-20472
Disclosed
06 Oct, 2015
Published
10 Jan, 2018