Arbitrary Code Execution

Affecting ruby-jss gem, versions <1.6.0

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

ruby-jss is a provides native ruby access to the REST APIs of Jamf Pro, an enterprise/education tool for managing Apple devices, from jamf.com.

Affected versions of this package are vulnerable to Arbitrary Code Execution. The Pixar ruby-jss gem allows remote attackers to execute arbitrary code because of the Plist gem's documented behavior of using Marshal.load during XML document processing.

Remediation

Upgrade ruby-jss to version 1.6.0 or higher.

References

CVSS Score

8.6
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    Low
  • Availability
    Low
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L
Credit
Unknown
CVE
CVE-2021-33575
CWE
CWE-94
Snyk ID
SNYK-RUBY-RUBYJSS-1729742
Disclosed
08 Oct, 2021
Published
08 Oct, 2021