Arbitrary Code Injection

Affecting rubygems-update gem, versions >=2.6.0, <2.7.9 || >=3.0.0, <3.0.2

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

rubygems-update is an inbuilt rubygem for updating rubygems.

Affected versions of this package are vulnerable to Arbitrary Code Injection due to the gem owner command outputs the contents of the API response directly to stdout. Therefore, if the response is crafted, escape sequence injection may occur.

Remediation

Upgrade rubygems-update to version 2.7.9, 3.0.2 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Credit
Unknown
CVE
CVE-2019-8322
CWE
CWE-94
Snyk ID
SNYK-RUBY-RUBYGEMSUPDATE-598861
Disclosed
20 Jun, 2019
Published
19 Aug, 2020