Man-in-the-Middle (MitM)

Affecting rubygems-update gem, versions <1.8.23

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

rubygems-update is an inbuilt rubygem for updating rubygems.

Affected versions of this package are vulnerable to Man-in-the-Middle (MitM). It can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack.

Remediation

Upgrade rubygems-update to version 1.8.23 or higher.

References

CVSS Score

5.4
medium severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    Low
  • Integrity
    Low
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
Credit
unknown
CVE
CVE-2012-2125
CWE
CWE-297
Snyk ID
SNYK-RUBY-RUBYGEMSUPDATE-472658
Disclosed
19 Apr, 2012
Published
14 Nov, 2019