Arbitrary Code Execution

Affecting rubygems-update gem, versions <2.6.13

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

rubygems-update is an inbuilt rubygem for updating rubygems.

Affected versions of this package are vulnerable to Arbitrary Code Execution. RubyGems version 2.6.12 and earlier fails to validate specification names, allowing a maliciously crafted gem to potentially overwrite any file on the filesystem.

Remediation

Upgrade rubygems-update to version 2.6.13 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N/E:P/RL:O/RC:C
Credit
Yusuke Endoh
CVE
CVE-2017-0901
CWE
CWE-20
Snyk ID
SNYK-RUBY-RUBYGEMSUPDATE-472655
Disclosed
27 Aug, 2017
Published
13 Nov, 2019