Arbitrary Code Execution

Affecting rubygems-update gem, versions <2.7.8 || >=3.0.0, <3.0.3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

rubygems-update is an inbuilt rubygem for updating rubygems.

Affected versions of this package are vulnerable to Arbitrary Code Execution. A crafted gem with a multi-line name is not handled correctly. Therefore, an attacker can inject arbitrary code to the stub line of gemspec, which is eval-ed by code in ensure_loadable_spec during the preinstall check.

Remediation

Upgrade rubygems-update to version 2.7.8, 3.0.3 or higher.

References

CVSS Score

8.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    Required
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Credit
nyangawa of Chaitin Tech
CVE
CVE-2019-8324
CWE
CWE-20
Snyk ID
SNYK-RUBY-RUBYGEMSUPDATE-472652
Disclosed
05 Mar, 2019
Published
13 Nov, 2019