Out-of-Bounds

Affecting rubygems-update gem, versions <2.7.8 || >=3.0.0, <3.0.3

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

rubygems-update is an inbuilt rubygem for updating rubygems.

Affected versions of this package are vulnerable to Out-of-Bounds. Gem::CommandManager#run calls alert_error without escaping, therefore escape sequence injection is possible.

Remediation

Upgrade rubygems-update to version 2.7.8, 3.0.3 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    High
  • Availability
    None
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Credit
ooooooo_q
CVE
CVE-2019-8325
CWE
CWE-119
Snyk ID
SNYK-RUBY-RUBYGEMSUPDATE-472646
Disclosed
05 Mar, 2019
Published
13 Nov, 2019