Infinite Loop

Affecting rubygems-update gem, versions <2.7.6

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

rubygems-update is an inbuilt rubygem for updating rubygems.

Affected versions of this package are vulnerable to Infinite Loop. Contains a infinite loop caused by negative size vulnerability in ruby gem package tar_header that can result in a negative size could cause an infinite loop.

Remediation

Upgrade rubygems-update to version 2.7.6 or higher.

References

CVSS Score

7.5
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    None
  • Integrity
    None
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Credit
Samuel Giddins
CVE
CVE-2018-1000075
CWE
CWE-835
Snyk ID
SNYK-RUBY-RUBYGEMSUPDATE-472644
Disclosed
15 Feb, 2018
Published
13 Nov, 2019