Arbitrary Code Injection

Affecting rubygems-update gem, versions <2.6.13

Report new vulnerabilities
Do your applications use this vulnerable package? Test your applications

Overview

rubygems-update is an inbuilt rubygem for updating rubygems.

Affected versions of this package are vulnerable to Arbitrary Code Injection. Is vulnerable to maliciously crafted gem specifications that include terminal escape characters. Printing the gem specification would execute terminal escape sequences.

Remediation

Upgrade rubygems-update to version 2.6.13 or higher.

References

CVSS Score

9.8
high severity
  • Attack Vector
    Network
  • Attack Complexity
    Low
  • Privileges Required
    None
  • User Interaction
    None
  • Scope
    Unchanged
  • Confidentiality
    High
  • Integrity
    High
  • Availability
    High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Credit
unknown
CVE
CVE-2017-0899
CWE
CWE-94
Snyk ID
SNYK-RUBY-RUBYGEMSUPDATE-472643
Disclosed
27 Aug, 2017
Published
13 Nov, 2019